autoprefixer: Replace color-adjust to print-color-adjust. The color-adjust shorthand is currently deprecated

Issue

I am getting this error how to solve it ?

I tried by installing this then also I am getting the problem

npm install autoprefixer@10.4.5 --save-exact

WARNING in ./node_modules/bootstrap/dist/css/bootstrap.min.css (./node_modules/css-loader/dist/cjs.js??ruleSet[1].rules[1].oneOf[5].use[1]!./node_modules/postcss-loader/dist/cjs.js??ruleSet[1].rules[1].oneOf[5].use[2]!./node_modules/source-map-loader/dist/cjs.js!./node_modules/bootstrap/dist/css/bootstrap.min.css)
Module Warning (from ./node_modules/postcss-loader/dist/cjs.js):
Warning

autoprefixer: Replace color-adjust to print-color-adjust. The color-adjust shorthand is currently deprecated.

webpack compiled with 1 warning

Solution

Add following line in package.json

For yarn:

"resolutions": {
    "autoprefixer": "10.4.5"
}

or if you’re using npm:

"overrides": {
    "autoprefixer": "10.4.5"
}

Answered By – Kamil Kuklewski

Answer Checked By – Timothy Miller (AngularFixing Admin)

Leave a Reply

Your email address will not be published.