can't run brand new angular project

Issue

First of all, YES, I did my research. I wen’t through suggested ‘Similar questions’ here on stackoverflow and I googled two days in a row. I wasn’t able to fix this problem yet.

The problem:

On my new PC I recently installed node.js, typescript and Angular.

I created a new project (let’s call the app reminder) like so

ng new reminder --style scss --prefix rem --routing

Immediately I try to run it, just to make sure it works

ng serve

And this is what I get back

An unhandled exception occurred: Could not find the implementation for
builder @angular-devkit/build-angular:dev-server

I’ve been looking for a solution since the day before yesterday – I tried to install the devkit/build-angular dev-server manually. I also tried multiple other things I found, but neither worked so far…

Any ideas, anybody?

Package                           Version
-----------------------------------------------------------
@angular-devkit/architect         0.13.9
@angular-devkit/build-angular     0.13.9
@angular-devkit/build-optimizer   0.13.9
@angular-devkit/build-webpack     0.13.9
@angular-devkit/core              7.3.9
@angular-devkit/schematics        8.1.0
@angular/cli                      8.1.0
@ngtools/webpack                  7.3.9
@schematics/angular               8.1.0
@schematics/update                0.801.0
rxjs                              6.3.3
typescript                        3.2.4
webpack                           4.29.0

THESE ARE JUST A FEW THINGS AMONG EVERYTHING I TRIED AND DIDN’T WORK:

// reinstall angular cli
npm uninstall -g @angular/cli
npm cache clean --force
npm install -g @angular/cli


// manually install devkit/build
npm install --save-dev @angular-devkit/build-angular


// reinstalled everything
uninstalled angular
uninstalled typescript
removed node
installed fresh node from nodejs.org
npm cache clean --force
npm chache verify
npm install @angular/cli --global

UPDATE:
I uninstalled angular/cli 8 and installed angular/cli 7.3.5 back as it was.
Now the server works.
I’ll wait for an answer to this question.

Solution

I struggled with this for over a week,
but none of the suggested (or googled) solutions worked.

I ended up ‘reseting’ my PC:
settings -> recovery -> reset this PC

After clean Windows, npm and Angular installs everything works.

Answered By – PaxForce

Answer Checked By – Katrina (AngularFixing Volunteer)

Leave a Reply

Your email address will not be published.