Codelyzer requires Angular 9 instead of Angular 10

Issue

When I am running the command npm ls -json in my node js project I get the following error:

npm ERR! missing: @angular/core@9.0.0, required by codelyzer@6.0.2
npm ERR! missing: @angular/compiler@9.0.0, required by codelyzer@6.0.2

@angular/core and @angular/compiler are already installed in the dependencies of my project, but with version 10.2.4

The error only occures when I am running yarn install to install my packages. If I am using npm install everything works fine, but takes a while.

Is there any version of codelyzer that uses Angular 10 instead of Angular 9 or some other package that solves the same problem?

Environment:

  • OS: Windows

  • Package Manager: yarn

  • Angular version: 10

Solution

I found out, that Codelyzer is deprecated and I had to remove it and install "eslint" package instead. EsLint has included all features of codelyzer.

Answered By – Camillo Carmesin

Answer Checked By – Timothy Miller (AngularFixing Admin)

Leave a Reply

Your email address will not be published.