ENOENT Error while trying to install Nativescript 8

Issue

I’m trying to build a new NS8 project. I have another NS6.5 project on my computer, but it’s in a different folder. When running npm install -g nativescript in a different folder, I get the following error

2323 verbose argv "/Users/.../.nvm/versions/node/v16.4.0/bin/node" "/Users/.../.nvm/versions/node/v16.4.0/bin/npm" "install" "-g" "nativescript"
2324 verbose node v16.4.0
2325 verbose npm  v7.18.1
2326 error code ENOENT
2327 error syscall lstat
2328 error path /Users/.../.npm/_cacache/content-v2/sha1/07/e1/3c3118154c53893d3be7a7e08d990e86d859
2329 error errno -2
2330 error enoent ENOENT: no such file or directory, lstat '/Users/.../.npm/_cacache/content-v2/sha1/07/e1/3c3118154c53893d3be7a7e08d990e86d859'
2331 error enoent This is related to npm not being able to find a file.
2332 verbose exit -2

I’m not sure why this is erroring out. Any help would be appreciated. Thanks

Solution

I solved this by installing node version 14.17.1 (v6.14.13)

Answered By – Jose Chavez

Answer Checked By – Cary Denson (AngularFixing Admin)

Leave a Reply

Your email address will not be published.