Error npm is known not to run on Node.js v10.24.1 and how to fix it, don't update to the latest version?

Issue

I run : npm run dev

Error : npm is known not to run on Node.js v10.24.1

I have researched and know the command: npm install -g npm@latest and some other commands to fix the problem

But the problem is that my project is using nodejs 10 so it can’t use the latest nodejs. So is there any way to fix the above error. Thank you

UPDATE :
I use nvm to install and manage versions of nodejs. And my OS is macOs

Solution

Thanks @Oduola Olumide Sunday for the response. I have followed your way but still not solved the problem.

And I fix it by removing the latest nodejs version and using the normal node v10.24.1

enter link description here ->
I removed the latest nodejs version with this

Answered By – Miedkes

Answer Checked By – Robin (AngularFixing Admin)

Leave a Reply

Your email address will not be published.