My WordPress featured image is not showing up on Facebook post and with Tweets

Issue

I’ve tinkered with the possibility that one of my plugins were messing up the featured image. Did not work.
I checked on FB debug tool this was the error message:

Invalid Image Content Type
Provided og:image URL, https://www.codexshopper.com/wp-content/uploads/2020/11/codexs.png could not be processed as an image because it has an invalid content type.

screenshot of the debug tool results

I’ve tried reuploading the same picture but with a different type like png and jpg, didn’t work too.

this is the detailed part, I tried to look at the og tags, but they’re all correct, nothing’s out of place.

<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>Services | Codex Shopper</title>
<meta name="description" content="Codex Shopper Free Business Listing, express your business the way you want others to feel, submit business for review.">
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large">
<link rel="canonical" href="https://www.codexshopper.com/services/">
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="Services | Codex Shopper">
<meta property="og:description" content="Codex Shopper Free Business Listing, express your business the way you want others to feel, submit business for review.">
<meta property="og:url" content="https://www.codexshopper.com/services/">
<meta property="og:site_name" content="Codex Shopper">
<meta property="og:updated_time" content="2020-11-14T04:16:17+00:00">
<meta property="og:image" content="https://www.codexshopper.com/wp-content/uploads/2020/11/codexs.png">
<meta property="og:image:secure_url" content="https://www.codexshopper.com/wp-content/uploads/2020/11/codexs.png">
<meta property="og:image:width" content="300">
<meta property="og:image:height" content="300">
<meta property="og:image:alt" content="Free Business Listing">
<meta property="og:image:type" content="image/png">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Services | Codex Shopper">
<meta name="twitter:description" content="Codex Shopper Free Business Listing, express your business the way you want others to feel, submit business for review.">
<meta name="twitter:site" content="@@Marketerextrao1">
<meta name="twitter:creator" content="@@Marketerextrao1">
<meta name="twitter:image" content="https://www.codexshopper.com/wp-content/uploads/2020/11/codexs.png">
<script type="application/ld+json" class="rank-math-schema">

Solution

I fixed it! I had to go on cPanel -_-, disable the hotlink protection. It was the one messing up my site.

Answered By – Codex Guy

Answer Checked By – Dawn Plyler (AngularFixing Volunteer)

Leave a Reply

Your email address will not be published.