VSCode Native script – Don't recognise breakpoints

Issue

I’m using native script angular in vscode with nativescript extension.
When I try to debug the application (ios) it doesn’t stop in the breakpoints and the editor doesn’t recognise the breakpoint.

In the debug console I can see the following messae "Error when trying to require webpack.config.js file from path ‘/Users/raulvaldoleiros/vscode-workspaces/ns-ng-course/webpack.config.js’. Error is: TypeError: host.onUnRecoverableConfigFileDiagnostic is not a function"

I also have uninstalled and installed webpack, added –debug-brk to arguments, executed ns migrate, created a new project from scratch and nothing seems to work.

launch.json

 {
        "name": "Launch on iOS", 
        "type": "nativescript",
        "request": "launch",
        "platform": "ios",
        "appRoot": "${workspaceRoot}",
        "sourceMaps": true,
        "watch": true
    }

Package.json

{
"name": "@nativescript/template-hello-world-ng",
  "main": "main.js",
  "version": "7.0.9",
  "author": "NativeScript Team <oss@nativescript.org>",
  "description": "NativeScript Application",
  "license": "SEE LICENSE IN <your-license-filename>",
  "publishConfig": {
    "access": "public"
  },
  "keywords": [
    "nativescript",
    "mobile",
    "angular",
    "{N}",
    "template"
  ],
  "repository": "<fill-your-repository-here>",
  "bugs": {
    "url": "https://github.com/NativeScript/NativeScript/issues"
  },
  "dependencies": {
    "@angular/animations": "~11.0.0",
    "@angular/common": "~11.0.0",
    "@angular/compiler": "~11.0.0",
    "@angular/core": "~11.0.0",
    "@angular/forms": "~11.0.0",
    "@angular/platform-browser": "~11.0.0",
    "@angular/platform-browser-dynamic": "~11.0.0",
    "@angular/router": "~11.0.0",
    "@nativescript/angular": "~11.0.0",
    "@nativescript/core": "~7.1.0",
    "@nativescript/schematics": "^11.0.0",
    "@nativescript/theme": "~3.0.0",
    "@nativescript/webpack": "3.0.0",
    "@schematics/angular": "^11.0.0",
    "project-helpers": "^0.4.0",
    "reflect-metadata": "~0.1.12",
    "rxjs": "^6.6.0",
    "tslint": "^6.1.3",
    "zone.js": "~0.11.1"
  },
  "devDependencies": {
    "@angular/cli": "^11.0.0",
    "@angular/compiler-cli": "~11.0.0",
    "@nativescript/android": "7.0.1",
    "@nativescript/ios": "7.2.0",
    "@nativescript/types": "~7.0.0",
    "@ngtools/webpack": "~11.0.0",
    "typescript": "~4.0.0"
  },
  "private": "true",
  "readme": "NativeScript Application"
}

Solution

You can follow the thread here :https://github.com/NativeScript/NativeScript/issues/9237#issuecomment-784933684

The solution is provided here:
https://github.com/NativeScript/NativeScript/issues/8930#issuecomment-751202147

Answered By – Raul Valdoleiros

Answer Checked By – Willingham (AngularFixing Volunteer)

Leave a Reply

Your email address will not be published.