Warning in npm config at latest version

Issue

I’m currently on npm@8.7.0 and every time I run any npm command I have this warning

npm WARN config init.author.email Use `--init-author-email` instead.
npm WARN config init.author.name Use `--init-author-name` instead.
npm WARN config init.license Use `--init-license` instead.

Does anyone knows how to remove these warnings, my global .npmrc only set those above settings

Solution

I set each one with the config setting the warning instructed.

i.e.

  • npm config set init-license MIT
  • npm config set init-version 0.0.1

Then delete the lines that contained the values in the old way:

  • init.license = MIT
  • init.version = 0.0.1

As a matter of testing, deleting the lines was enough to make the warning cease. However, after testing the values set in the new format; npm init was picking them up.

Answered By – user_pt

Answer Checked By – Willingham (AngularFixing Volunteer)

Leave a Reply

Your email address will not be published.